summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--flake.nix50
1 files changed, 50 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..fe65357
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,50 @@
+{
+ description = "logic-rust - project to solve course work for Computer Circuit Design";
+
+ inputs = {
+ flake-utils.url = "github:numtide/flake-utils";
+ nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
+
+ rust-overlay = {
+ url = "github:oxalica/rust-overlay";
+ inputs.nixpkgs.follows = "nixpkgs";
+ inputs.flake-utils.follows = "flake-utils";
+ };
+ };
+
+ outputs =
+ {
+ flake-utils,
+ nixpkgs,
+ rust-overlay,
+ self,
+ ...
+ }@inputs:
+ flake-utils.lib.eachSystem [ "x86_64-linux" ] (
+ system:
+ let
+ pkgs = import nixpkgs {
+ inherit system;
+ overlays = [
+ rust-overlay.overlays.default
+ ];
+ };
+ in
+ {
+ devShells.default = pkgs.mkShell {
+ packages = with pkgs; [
+ bacon
+ (rust-bin.selectLatestNightlyWith (
+ toolchain:
+ toolchain.default.override {
+ extensions = [
+ "rust-analyzer"
+ "rust-src"
+ ];
+ }
+ ))
+ ];
+ };
+ }
+ );
+}