summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--flake.nix11
1 files changed, 9 insertions, 2 deletions
diff --git a/flake.nix b/flake.nix
index aafbfaa..679cedd 100644
--- a/flake.nix
+++ b/flake.nix
@@ -38,6 +38,10 @@
# for specific tags, branches and commits, see:
# https://nixos.org/manual/nix/stable/command-ref/new-cli/nix3-flake.html#examples
+ plugins-leap-spooky-nvim = {
+ url = "github:ggandor/leap-spooky.nvim";
+ flake = false;
+ };
};
# see :help nixCats.flake.outputs
@@ -103,7 +107,7 @@
# This is for plugins that will load at startup without using packadd:
startupPlugins = {
- gitPlugins = with pkgs.neovimPlugins; [ ];
+ gitPlugins = with pkgs.neovimPlugins; { };
general = with pkgs.vimPlugins; {
always = [ lze lzextras ];
@@ -117,9 +121,12 @@
# not loaded automatically at startup.
# use with packadd and an autocommand in config to achieve lazy loading
optionalPlugins = {
- gitPlugins = with pkgs.neovimPlugins; [ ];
+ gitPlugins = with pkgs.neovimPlugins; {
+ leap = [ leap-spooky-nvim ];
+ };
general = with pkgs.vimPlugins; {
+ leap = [ leap-nvim flit-nvim ];
telescope = [ telescope-nvim ];
extra = [ which-key-nvim ];
};