aboutsummaryrefslogtreecommitdiff
path: root/user-mora.nix
diff options
context:
space:
mode:
authorLibravatar Mora Unie Youer <[email protected]>2025-02-27 21:39:45 +0300
committerLibravatar Mora Unie Youer <[email protected]>2025-02-27 21:39:45 +0300
commite9288801b633b1948eeb58c0f9796f85b9ef7301 (patch)
treefefd826a2bcd6e8b0121111dc169c2ba3614ed2e /user-mora.nix
parentfeat(sapphire): enable XDG portal for graphics environment (diff)
downloadnixos-configuration-e9288801b633b1948eeb58c0f9796f85b9ef7301.tar.gz
nixos-configuration-e9288801b633b1948eeb58c0f9796f85b9ef7301.tar.bz2
nixos-configuration-e9288801b633b1948eeb58c0f9796f85b9ef7301.tar.lz
nixos-configuration-e9288801b633b1948eeb58c0f9796f85b9ef7301.tar.xz
nixos-configuration-e9288801b633b1948eeb58c0f9796f85b9ef7301.tar.zst
nixos-configuration-e9288801b633b1948eeb58c0f9796f85b9ef7301.zip
feat(mora): configure basic stuff
Diffstat (limited to '')
-rw-r--r--user-mora.nix105
1 files changed, 104 insertions, 1 deletions
diff --git a/user-mora.nix b/user-mora.nix
index 14fb481..f2771cc 100644
--- a/user-mora.nix
+++ b/user-mora.nix
@@ -1,7 +1,110 @@
-_:
+{ inputs, pkgs, ... }:
{
home.stateVersion = "24.11";
home.username = "mora";
home.homeDirectory = "/home/mora";
+
+ ###
+ ### Shells
+ ###
+ programs.bash.enable = true;
+ programs.fish.enable = true;
+ programs.nushell.enable = true;
+
+
+ ###
+ ### Software
+ ###
+ programs.eza.enable = true;
+ programs.ripgrep.enable = true;
+ programs.zoxide.enable = true;
+
+ programs.neovim.enable = true;
+ programs.neovim.defaultEditor = true;
+
+ programs.git = {
+ enable = true;
+ delta.enable = true;
+ includes = [{
+ contents = {
+ user.name = "Mora Unie Youer";
+ user.email = "[email protected]";
+ user.signingKey = "0x7AB91D83B25E6D7F";
+ commit.gpgSign = true;
+ init.defaultBranch = "master";
+ safe.directory = "*";
+ };
+ }];
+ };
+
+ programs.gpg = {
+ enable = true;
+ settings = {
+ ask-cert-level = true;
+ expert = true;
+ list-options = [ "show-sig-expire" "show-uid-validity" "show-unusable-subkeys" "show-unusable-uids"];
+ verify-options = [ "show-uid-validity" "show-unusable-uids" ];
+ with-fingerprint = [ "" "" ]; # Repeat with-fingerprint twice
+ with-keygrip = true;
+ };
+ };
+
+ services.gpg-agent = {
+ enable = true;
+ enableSshSupport = true;
+ pinentryPackage = pkgs.pinentry-gnome3;
+ };
+
+ services.gnome-keyring = {
+ enable = true;
+ components = [ "secrets" "ssh" ];
+ };
+
+
+ ###
+ ### Customization
+ ###
+ gtk.enable = true;
+ gtk.font.name = "DejaVu Sans";
+ gtk.font.size = 8;
+ gtk.cursorTheme = {
+ package = pkgs.catppuccin-cursors.mochaMauve;
+ name = "catppuccin-mocha-mauve-cursors";
+ };
+
+ home.pointerCursor = {
+ package = pkgs.catppuccin-cursors.mochaMauve;
+ name = "catppuccin-mocha-mauve-cursors";
+ size = 32;
+ gtk.enable = true;
+ x11.enable = true;
+ };
+
+
+ ###
+ ### Extra Packages
+ ###
+ home.packages = with pkgs; [
+ # Fonts
+ liberation_ttf
+ noto-fonts
+ noto-fonts-cjk-sans
+ noto-fonts-emoji
+
+ font-awesome
+ nerd-fonts._0xproto
+ nerd-fonts.fira-code
+
+ # Utils
+ libnotify
+ xdg-utils
+ wl-clipboard
+
+ # Shell
+ python3
+
+ # Applications
+ inputs.wezterm.packages.${pkgs.system}.default
+ ];
}