aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--flake.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index db86f4f..e921f49 100644
--- a/flake.nix
+++ b/flake.nix
@@ -7,6 +7,8 @@
inputs = {
nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";
+ nix-filter.url = "github:numtide/nix-filter";
+
flake-compat = {
url = "github:edolstra/flake-compat";
flake = false;
@@ -60,9 +62,17 @@
fjordlauncher = {
url = "github:unmojang/FjordLauncher";
inputs.nixpkgs.follows = "nixpkgs";
+ inputs.nix-filter.follows = "nix-filter";
inputs.flake-compat.follows = "flake-compat";
};
+ niri = {
+ url = "github:YaLTeR/niri";
+ inputs.nixpkgs.follows = "nixpkgs";
+ inputs.nix-filter.follows = "nix-filter";
+ inputs.rust-overlay.follows = ""; # NOTE: for end user is not requried
+ };
+
wezterm = {
url = "github:wezterm/wezterm?dir=nix";
inputs.nixpkgs.follows = "nixpkgs";
@@ -98,6 +108,7 @@
musnix,
fjordlauncher,
+ niri,
wezterm,
...
@@ -121,6 +132,7 @@
{
nixpkgs.overlays = [
fjordlauncher.overlays.default
+ niri.overlays.default
];
}