aboutsummaryrefslogtreecommitdiff
path: root/user-mora.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--user-mora.nix11
1 files changed, 9 insertions, 2 deletions
diff --git a/user-mora.nix b/user-mora.nix
index 5a4dea3..3a00430 100644
--- a/user-mora.nix
+++ b/user-mora.nix
@@ -1,5 +1,11 @@
{ inputs, pkgs, ... }:
+let
+ # NOTE: pinned nixpkgs to reduce updating huge packages
+ pkgs-pinned = import inputs.nixpkgs-pinned {
+ inherit (pkgs) system;
+ };
+in
{
home.stateVersion = "24.11";
home.username = "mora";
@@ -81,7 +87,7 @@
};
home.pointerCursor = let
- catppuccin-cursors' = pkgs.catppuccin-cursors.overrideAttrs (prev: {
+ catppuccin-cursors' = pkgs-pinned.catppuccin-cursors.overrideAttrs (prev: {
patchPhase = ''
# FIX: GTK3-4 is screaming ;_;
sed -i scripts/build-cursors -e 's/NOMINAL_SIZE=24/NOMINAL_SIZE=32/'
@@ -133,7 +139,8 @@
_64gram
fjordlauncher
- kicad
+
+ pkgs-pinned.kicad
];
###