aboutsummaryrefslogtreecommitdiff
path: root/user-mora.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--user-mora.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/user-mora.nix b/user-mora.nix
index b03e72f..e62c832 100644
--- a/user-mora.nix
+++ b/user-mora.nix
@@ -139,4 +139,15 @@
Restart = "on-failure";
};
};
+
+ systemd.user.services.xwayland-satellite = {
+ Unit.PartOf = [ "graphical-session.target" ];
+ Unit.After = [ "niri.service" ];
+ Unit.Wants = [ "niri.service" ];
+ Install.WantedBy = [ "graphical-session.target" ];
+ Service = {
+ ExecStart = "${pkgs.xwayland-satellite}/bin/xwayland-satellite";
+ Restart = "on-failure";
+ };
+ };
}