From 6a0b1b611688aa0beaaddc8d80c573b9ba9454d3 Mon Sep 17 00:00:00 2001
From: Mora Unie Youer <mora_unie_youer@riseup.net>
Date: Sun, 2 Mar 2025 11:11:55 +0300
Subject: feat(sapphire): reuse system nixpkgs in command line tools

---
 system-sapphire.nix | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)

(limited to 'system-sapphire.nix')

diff --git a/system-sapphire.nix b/system-sapphire.nix
index 1389795..6372449 100644
--- a/system-sapphire.nix
+++ b/system-sapphire.nix
@@ -1,4 +1,4 @@
-{ modulesPath, config, lib, pkgs, ... }:
+{ inputs, modulesPath, config, lib, pkgs, ... }:
 
 {
   ###
@@ -8,6 +8,10 @@
   system.stateVersion = "25.05";
   nixpkgs.config.allowUnfree = true;
 
+  # Use the same nixpkgs for system and for `nix-shell` and `nix shell`
+  nix.registry.nixpkgs.flake = inputs.nixpkgs;
+  nix.nixPath = [ "nixpkgs=${inputs.nixpkgs.outPath}" "/nix/var/nix/profiles/per-user/root/channels" ];
+
   ###
   ### Filesystems
   ###
-- 
cgit v1.2.3-70-g09d2