diff options
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 36 |
1 files changed, 34 insertions, 2 deletions
@@ -47,6 +47,11 @@ url = "github:rasulomaroff/telepath.nvim"; flake = false; }; + + plugins-multicursor-nvim = { + url = "github:jake-stewart/multicursor.nvim"; + flake = false; + }; }; # see :help nixCats.flake.outputs @@ -150,6 +155,17 @@ # cargo rust-analyzer ]; + + typescript = [ + angular-language-server + biome + prettierd + typescript-language-server + ]; + + debug = [ + lldb + ]; }; }; @@ -191,6 +207,10 @@ leap-spooky-nvim telepath-nvim ]; + + extra = [ + multicursor-nvim + ]; }; general = with pkgs.vimPlugins; { @@ -207,11 +227,12 @@ treesitter = [ nvim-treesitter.withAllGrammars nvim-treesitter-textobjects + nvim-ts-autotag ]; completion = [ blink-cmp ]; # NOTE: On NeoVim 0.11+ nvim-lspconfig is not required due to native API - lsp = [ ]; + lsp = [ lazydev-nvim ]; mini = [ mini-ai @@ -227,13 +248,24 @@ git = [ gitsigns-nvim ]; + debug = [ + nvim-dap + nvim-dap-ui + nvim-dap-virtual-text + ]; + ui = [ bufferline-nvim + lualine-nvim noice-nvim todo-comments-nvim ]; - extra = [ which-key-nvim ]; + extra = [ + oil-nvim + yanky-nvim + which-key-nvim + ]; }; }; |