aboutsummaryrefslogtreecommitdiff
path: root/system-sapphire.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system-sapphire.nix')
-rw-r--r--system-sapphire.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/system-sapphire.nix b/system-sapphire.nix
index 6f9ddc8..8661001 100644
--- a/system-sapphire.nix
+++ b/system-sapphire.nix
@@ -124,6 +124,13 @@
environment.systemPackages = with pkgs; [ git git-crypt ];
+ xdg.portal = {
+ enable = true;
+ config.common.default = [ "gtk" "gnome" ];
+ extraPortals = with pkgs; [ xdg-desktop-portal-gtk xdg-desktop-portal-gnome ];
+ };
+
+
# NOTE: I now use this as alternative to steam-run'ing every precompiled binary
# This should be much easier now, than `steam-run <binary>` every time
services.envfs.enable = true;