diff options
author | 2025-03-30 14:22:44 +0300 | |
---|---|---|
committer | 2025-03-30 14:22:44 +0300 | |
commit | 7332f182974f64c382dc25099f54c2eb0c7beebc (patch) | |
tree | 6c4b729f3481a3035657e621daf399c795b393fa /flake.nix | |
parent | fix(sapphire): disable scx scheduler (diff) | |
download | nixos-configuration-master.tar.gz nixos-configuration-master.tar.bz2 nixos-configuration-master.tar.lz nixos-configuration-master.tar.xz nixos-configuration-master.tar.zst nixos-configuration-master.zip |
Diffstat (limited to '')
-rw-r--r-- | flake.nix | 73 |
1 files changed, 45 insertions, 28 deletions
@@ -129,29 +129,31 @@ ]; }; - outputs = { - self, + outputs = + { + self, - nixpkgs, - nurpkgs, - nyxpkgs, - home-manager, + nixpkgs, + nurpkgs, + nyxpkgs, + home-manager, - lanzaboote, + lanzaboote, - musnix, + musnix, - fjordlauncher, - niri, - wezterm, + fjordlauncher, + niri, + wezterm, - neovim-configuration, + neovim-configuration, - ... - } @ inputs: + ... + }@inputs: let system = "x86_64-linux"; - in { + in + { nixosConfigurations.sapphire = nixpkgs.lib.nixosSystem rec { inherit system; specialArgs = { inherit inputs; }; @@ -173,7 +175,10 @@ } { - nix.trustedUsers = [ "root" "mora" ]; + nix.trustedUsers = [ + "root" + "mora" + ]; } # System Configuration @@ -182,18 +187,30 @@ # User Configurations # mora@sapphire - ({ pkgs, ... }: { - users.users.mora = { - isNormalUser = true; - extraGroups = [ "audio" "docker" "libvirtd" "lp" "scanner" "video" "wireshark" "wheel" ]; - shell = pkgs.nushell; - }; - - home-manager.useGlobalPkgs = true; - home-manager.useUserPackages = true; - home-manager.extraSpecialArgs = specialArgs; - home-manager.users.mora = import ./user-mora.nix; - }) + ( + { pkgs, ... }: + { + users.users.mora = { + isNormalUser = true; + extraGroups = [ + "audio" + "docker" + "libvirtd" + "lp" + "scanner" + "video" + "wireshark" + "wheel" + ]; + shell = pkgs.nushell; + }; + + home-manager.useGlobalPkgs = true; + home-manager.useUserPackages = true; + home-manager.extraSpecialArgs = specialArgs; + home-manager.users.mora = import ./user-mora.nix; + } + ) ]; }; }; |