aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--flake.nix73
1 files changed, 45 insertions, 28 deletions
diff --git a/flake.nix b/flake.nix
index 66d120c..862736e 100644
--- a/flake.nix
+++ b/flake.nix
@@ -129,29 +129,31 @@
];
};
- outputs = {
- self,
+ outputs =
+ {
+ self,
- nixpkgs,
- nurpkgs,
- nyxpkgs,
- home-manager,
+ nixpkgs,
+ nurpkgs,
+ nyxpkgs,
+ home-manager,
- lanzaboote,
+ lanzaboote,
- musnix,
+ musnix,
- fjordlauncher,
- niri,
- wezterm,
+ fjordlauncher,
+ niri,
+ wezterm,
- neovim-configuration,
+ neovim-configuration,
- ...
- } @ inputs:
+ ...
+ }@inputs:
let
system = "x86_64-linux";
- in {
+ in
+ {
nixosConfigurations.sapphire = nixpkgs.lib.nixosSystem rec {
inherit system;
specialArgs = { inherit inputs; };
@@ -173,7 +175,10 @@
}
{
- nix.trustedUsers = [ "root" "mora" ];
+ nix.trustedUsers = [
+ "root"
+ "mora"
+ ];
}
# System Configuration
@@ -182,18 +187,30 @@
# User Configurations
# mora@sapphire
- ({ pkgs, ... }: {
- users.users.mora = {
- isNormalUser = true;
- extraGroups = [ "audio" "docker" "libvirtd" "lp" "scanner" "video" "wireshark" "wheel" ];
- shell = pkgs.nushell;
- };
-
- home-manager.useGlobalPkgs = true;
- home-manager.useUserPackages = true;
- home-manager.extraSpecialArgs = specialArgs;
- home-manager.users.mora = import ./user-mora.nix;
- })
+ (
+ { pkgs, ... }:
+ {
+ users.users.mora = {
+ isNormalUser = true;
+ extraGroups = [
+ "audio"
+ "docker"
+ "libvirtd"
+ "lp"
+ "scanner"
+ "video"
+ "wireshark"
+ "wheel"
+ ];
+ shell = pkgs.nushell;
+ };
+
+ home-manager.useGlobalPkgs = true;
+ home-manager.useUserPackages = true;
+ home-manager.extraSpecialArgs = specialArgs;
+ home-manager.users.mora = import ./user-mora.nix;
+ }
+ )
];
};
};